Tutorial Completo ūüĎČ Instalar DOCKER en OpenMediaVault 6 como ellos manda

Buenas a todos, en este v√≠deo vamos a ver como instalar el nuevo sistema de Docker integrado de OpenMediaVault, a continuaci√≥n os dejo el primer comando que ten√©is que poner para poder instalar las OMV-Extras. Tambi√©n m√°s abajo, como habilitar el repositorio e instalar. Por √ļltimo, pod√©is encontrar en enlace a su gu√≠a.

Instalar openmediavault-omvextrasorg.
wget -O - https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash
Habilite el repositorio docker. En la GUI en System > omv-extras, haga clic en el botón Docker repo
    • En la¬†GUI¬†de OMV, vaya a¬†System¬†>¬†Plugins¬†busque y seleccione el complemento, luego haga clic en¬†Instalar¬†en el men√ļ superior.
  • Crear el usuario ¬ęappuser¬Ľ

    • En la¬†GUI¬†OMV vaya a Usuarios >¬†Usuarios¬†haga clic¬†en el bot√≥n¬†+Crear
      • Definir el nombre de¬†usuario de la aplicaci√≥n
      • Asignar contrase√Īa.
      • En el campo de grupos lo agregamos a los grupos¬†docker¬†y¬†usuarios.
        • La pertenencia a estos grupos debe garantizar que¬†appuser¬†tenga permisos de escritura en las carpetas¬†docker,¬†appdata¬†y¬†compose. Compru√©balo. Si no es as√≠, aseg√ļrese de que los permisos de carpeta son 775, el propietario es¬†root¬†y el grupo propietario es¬†usuarios. Consulte¬†Permisos de NAS en OMV
        • Si necesita restablecer algunos permisos en su NAS, puede usar¬†el complemento Reset Permissions para OMV6
      • Haga clic en¬†Guardar.
    • Abra las columnas UID y GID y anote los valores que tiene el usuario¬†appuser.
      • Ejemplo: UID=1002 GID=100
      • Si ya ten√≠a un usuario, el UID¬†del usuario de la aplicaci√≥n¬†ser√° 1001. Si ten√≠a 2 usuarios, el UID¬†del usuario de la aplicaci√≥n¬†ser√° 1002, etc. Esto puede variar en su sistema.
    • Aseg√ļrese de que el¬†usuario appuser¬†tiene los permisos de lectura o lectura/escritura necesarios, seg√ļn el caso, en las carpetas incluidas en cada contenedor. Puede usar la¬†GUI¬†de OMV para hacer esto.

OMV6:docker_in_omv [omv-extras.org]


Categories:


Comments

6 respuestas a «Tutorial Completo ūüĎČ Instalar DOCKER en OpenMediaVault 6 como ellos manda»

  1. Avatar de Konansia
    Konansia

    Hola.

    Obtengo este error:

    wget -O – https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash
    –2023-09-17 18:31:27– https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install
    Resolviendo github.com (github.com)… fall√≥: Nombre o servicio desconocido.
    wget: no se pudo resolver la direcci√≥n del equipo ¬ęgithub.com¬Ľ

    Qué hago mal?

    Gracias

    1. Avatar de Gamba

      Hola, comprueba que se ha copiado bien wget -O – https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash
      Si no, en su web puedes copiarlo por si acaso https://wiki.omv-extras.org/doku.php?id=start
      Avísame si te funciona uno u otro. Un saludo.

      1. Avatar de Jose d
        Jose d

        Hola tengo el mismo problema, lo he copiado correctamete y siempre me dice el mismo error.
        Hay alguna solucion?
        Gracias, un saludo

  2. Avatar de Manuel
    Manuel

    Buenos dias,
    Al intentar instalar el omv me da el siguiente error:
    Redirecting output to ‚Äėwget-log.3‚Äô.
    [2023-12-09 19:39:40+0000] [omvinstall] version :: 2.2.3
    [2023-12-09 19:39:40+0000] [omvinstall] Starting …
    [2023-12-09 19:39:40+0000] [omvinstall] Current / permissions = 755
    mode of ‘/’ retained as 0755 (rwxr-xr-x)
    [2023-12-09 19:39:40+0000] [omvinstall] New / permissions = 755
    [2023-12-09 19:39:40+0000] [omvinstall] Forcing IPv4 only for apt…
    [2023-12-09 19:39:40+0000] [omvinstall] Updating repos before installing…
    Hit:1 http://deb.debian.org/debian bookworm InRelease
    Hit:2 http://deb.debian.org/debian-security bookworm-security InRelease
    Hit:3 http://deb.debian.org/debian bookworm-updates InRelease
    Hit:4 http://archive.raspberrypi.com/debian bookworm InRelease
    Reading package lists…
    [2023-12-09 19:39:42+0000] [omvinstall] Installing lsb_release…
    Reading package lists…
    Building dependency tree…
    Reading state information…
    0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
    Need to get 0 B/6416 B of archives.
    After this operation, 0 B of additional disk space will be used.
    (Reading database … 54958 files and directories currently installed.)
    Preparing to unpack …/lsb-release_12.0-1_all.deb …
    Unpacking lsb-release (12.0-1) over (12.0-1) …
    Setting up lsb-release (12.0-1) …
    Processing triggers for man-db (2.11.2-2) …
    [2023-12-09 19:39:45+0000] [omvinstall] Arch :: arm64
    [2023-12-09 19:39:45+0000] [omvinstall] Supported architecture
    [2023-12-09 19:39:45+0000] [omvinstall] Codename :: bookworm
    [2023-12-09 19:39:45+0000] [omvinstall] Unsupported version. Only Debian 10 (Buster) and 11 (Bullseye) are supported. Exiting…

    Entiendo que es por incompatibilidad con el sistema, el OS es el raspberry lite descargado e instalo en una sd desde el raspberry Pi imager,
    sabrías decirme como puedo instalarlo? gracias,

    1. Avatar de Gamba

      Buenas, comprueba que el sistema operativo que tienes instalado es de 64 Bit y que es sin escritorio.

    2. Avatar de Gamba

      Buenas, tienes que instalar la versión de 64 bits normal sin escritorio.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si contin√ļa navegando est√° dando su consentimiento para la aceptaci√≥n de las mencionadas cookies y la aceptaci√≥n de nuestra pol√≠tica de cookies, pinche el enlace para mayor informaci√≥n.plugin cookies

ACEPTAR
Aviso de cookies